flight_co2_calculator_flutter 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 52

Flight CO2 Calculator #

About #

This plugin provides a collection of classes that can be used to:

  • Load a list of airports from the OpenFlights.org dataset.
  • Lookup airports matching a search query against the entire data-set of airports.
  • Calculate the distance and CO2 emissions from flights.

What you can do with this #

Build a Flight CO2 Calculator app such as this:

How to use it #

Load data:

List<Airport> airports = await AirportDataReader.load('data/airports.dat');

Create an AirportLookup service:

final airportLookup = AirportLookup(airports: airports);

Search for airports matching a query:

List<Airport> results = airportLookup.searchString(query);

Calculate distance and CO2 emissions:

class FlightCalculationData {
  FlightCalculationData({this.distanceKm, this.co2e});
  final double distanceKm;
  final double co2e;
}

FlightCalculationData _calculate(FlightDetails flightDetails) {
  double distanceKm;
  double co2e;
  Airport departure = flightDetails.departure;
  Airport arrival = flightDetails.arrival;
  if (departure != null && arrival != null) {
    double multiplier =
        flightDetails.flightType == FlightType.oneWay ? 1.0 : 2.0;
    distanceKm = DistanceCalculator.distanceInKmBetween(
        departure.location, arrival.location);
    distanceKm = CO2Calculator.correctedDistanceKm(distanceKm);
    co2e =
        CO2Calculator.calculateCO2e(distanceKm, flightDetails.flightClass) *
            multiplier;
  }
  return FlightCalculationData(distanceKm: distanceKm, co2e: co2e);
}

Example #

See the sample Flight CO2 Calculator app bundled with the project in the example folder.

License: MIT #

0.0.1 - Initial Release #

  • Add Airport class
  • Add AirportDataReader class
  • Add AirportLookup class
  • Add FlightClass enum
  • Add DistanceCalculator class
  • Add CO2Calculator class

example/README.md

flight_co2_calculator_flutter_example #

Demonstrates how to use the flight_co2_calculator_flutter plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flight_co2_calculator_flutter: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flight_co2_calculator_flutter/flight_co2_calculator_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
13
Health:
Code health derived from static analysis. [more]
92
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
52
Learn more about scoring.

We analyzed this package on Nov 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

46 out of 46 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/co2_calculator.dart. (-4.41 points)

Analysis of lib/co2_calculator.dart reported 9 hints, including:

line 10 col 10: Name non-constant identifiers using lowerCamelCase.

line 11 col 10: Name non-constant identifiers using lowerCamelCase.

line 12 col 10: Name non-constant identifiers using lowerCamelCase.

line 16 col 10: Name non-constant identifiers using lowerCamelCase.

line 25 col 16: Name non-constant identifiers using lowerCamelCase.

Fix lib/distance_calculator.dart. (-2.48 points)

Analysis of lib/distance_calculator.dart reported 5 hints:

line 13 col 12: Name non-constant identifiers using lowerCamelCase.

line 17 col 12: Name non-constant identifiers using lowerCamelCase.

line 18 col 12: Name non-constant identifiers using lowerCamelCase.

line 20 col 12: Name non-constant identifiers using lowerCamelCase.

line 21 col 12: Name non-constant identifiers using lowerCamelCase.

Fix lib/airport_data_reader.dart. (-0.50 points)

Analysis of lib/airport_data_reader.dart reported 1 hint:

line 5 col 10: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/airport.dart (Run flutter format to format lib/airport.dart.)
  • lib/airport_lookup.dart (Run flutter format to format lib/airport_lookup.dart.)
  • lib/flight_class.dart (Run flutter format to format lib/flight_class.dart.)

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8