flickr 0.0.1

  • Installing
  • Versions
  • 0

About #

Dartlang wrapper for flickr API calls.

Install #

In your pubspec.yaml:


Documentation #

Testing #

For tests to pass, set FLICKR_API_KEY obtained from request api key in your system variables:

$ export FLICKR_API_KEY="..."

Then run:

$ pub run test

Server #

import 'package:shelf/shelf.dart' as shelf;
import 'package:shelf/shelf_io.dart' as io;
import 'package:flickr/flickr_shelf.dart' as flickr;

main() {
  var port = 9999;
  var apiKey = Platform.environment['FLICKR_API_KEY'];
  var f = new flickr.Flickr(apiKey);
  var handler = const shelf.Pipeline()

  var server = await io.serve(handler, '', port);

Client #

import 'package:flickr/flickr_client.dart' as flickr;

main() async {
  var rootUrl = 'host url without http or https'; // example:
  var api = new flickr.FlickrApi(rootUrl);

  var result ='cats', 1);
  var photos = result.entries;
  var photo = photos.first;
  var smallPhotoUri = photo.smallSquareUri;

Changelog #

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flickr: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flickr/flickr.dart';
Version Uploaded Documentation Archive
0.0.1 Mar 23, 2017 Go to the documentation of flickr 0.0.1 Download flickr 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0