flatten 1.0.0

  • README.md
  • Installing
  • Versions
  • 0

flatten #

version 1.0.0 build status

Optimizes a router by condensing all its routes into one level. This only works with package:angel_route.

package:angel_route is an ultra-powerful router that works across all platforms. It supports nested groups, and an advanced middleware system. The caveat is, route groups and middleware exist at different levels within the hierarchy when nested. Flattening a router condenses all routes into one level, and inlines route handlers, so that paths can be resolved much faster.

The Angel framework uses a flattened router in production mode to optimize servers.

Installation #

In your pubspec.yaml:

  angel_route: ^1.0.0
  flatten: ^1.0.0

Usage #

import 'package:angel_route/angel_route.dart'; import 'package:flatten/flatten.dart';

var flattened = flatten(myRouter);

Caveats #

This package doesn't actually modify the existing router; instead, it creates a new one. Routes adding to the original router after flattening will not be present in the new router.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flatten: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flatten/flatten.dart';
Version Uploaded Documentation Archive
1.0.0 Mar 31, 2017 Go to the documentation of flatten 1.0.0 Download flatten 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0