flamingo_generator 0.13.0
flamingo_generator: ^0.13.0 copied to clipboard

Automatically generate code for converting flamingo JSON by annotating Dart classes.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add flamingo_generator

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  flamingo_generator: ^0.13.0

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:flamingo_generator/flamingo_generator.dart';
1
likes
110
pub points
48%
popularity

Publisher

neverjp.com

Automatically generate code for converting flamingo JSON by annotating Dart classes.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, flamingo_annotation, meta, source_gen

More

Packages that depend on flamingo_generator