firestore_ref 0.7.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 82

firestore_ref #

Cross-platform(including web) Firestore type-safe wrapper.

[0.7.0] #

  • Delete helper methods in favor of cloud_firestore_web

[0.6.0] #

[0.5.1] #

[0.5.0] #

  • Update dependencies

[0.4.1] #

  • Fix documentID bug

[0.4.0] #

  • Dart version: >=2.6.0-dev
  • Use extension

[0.3.0] #

  • Update to firebase 6.0.0
  • Support collection group query for web

[0.2.2] #

  • Set configureFirestore's persistenceEnabled default value to true.

[0.2.1] #

  • Rename to data from json

[0.2.0] #

  • Support for web.

[0.1.0] #

  • Several enhancements.

[0.0.3] #

  • Support batch write.

[0.0.2] #

  • Add parseJson.

[0.0.1] #

  • Initial release.

example/lib/main.dart

import 'package:firestore_ref/firestore_ref.dart';
import 'package:flutter/material.dart';

import 'app.dart';
import 'model/service/service.dart';
import 'util/util.dart';

void main() {
  logger.fine('start');
  WidgetsFlutterBinding.ensureInitialized();
  Firestore.instance.settings(persistenceEnabled: true);
  runApp(
    MultiProvider(
      providers: [
        Provider(create: (context) => AppInfo()),
        ChangeNotifierProvider(
          create: (context) => Authenticator()..signInAnonymously(),
        ),
      ],
      child: App(),
    ),
  );
}

class AppInfo {
  String get title => 'Firebase Counter';
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firestore_ref: ^0.7.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firestore_ref/firestore_ref.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
65
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
82
Learn more about scoring.

We analyzed this package on Mar 30, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
cloud_firestore ^0.13.2+1 0.13.4+2
firebase ^7.2.1 7.2.1
flutter 0.0.0
json_annotation ^3.0.1 3.0.1
meta ^1.1.8 1.1.8
simple_logger ^1.6.0+1 1.7.0
Transitive dependencies
async 2.4.1
charcode 1.1.3
cloud_firestore_platform_interface 1.1.0
cloud_firestore_web 0.1.1+2
collection 1.14.11 1.14.12
firebase_core 0.4.4+3
firebase_core_platform_interface 1.0.4
firebase_core_web 0.1.1+2
flutter_web_plugins 0.0.0
http 0.12.0+4
http_parser 3.1.4
js 0.6.1+1
logging 0.11.4
matcher 0.12.6
path 1.6.4
pedantic 1.9.0
plugin_platform_interface 1.0.2
quiver 2.1.3
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
pedantic_mono any