firecross 0.0.2+6

firecross #

Cross platform firebase

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firecross: ^0.0.2+6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firecross/firecross.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
31
Overall:
Weighted score of the above. [more]
36
Learn more about scoring.

We analyzed this package on Jul 6, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:firecross/firecross.dart, package:firecross/firecross_app.dart, package:firecross/src/mobile/firecross_app.dart, package:firecross/src/mobile/firecross_auth.dart, package:firebase_auth/firebase_auth.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:firecross/firecross.dart, package:firecross/firecross_app.dart, package:firecross/src/mobile/firecross_app.dart, package:firecross/src/mobile/firecross_auth.dart, package:firebase_auth/firebase_auth.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:firecross/firecross.dart, package:firecross/firecross_app.dart, package:firecross/src/mobile/firecross_app.dart, package:firecross/src/mobile/firecross_auth.dart, package:firebase_auth/firebase_auth.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [firecross] that is in a package requiring null.

Health suggestions

Format lib/firecross.dart.

Run flutter format to format lib/firecross.dart.

Format lib/firecross_app.dart.

Run flutter format to format lib/firecross_app.dart.

Format lib/firecross_auth.dart.

Run flutter format to format lib/firecross_auth.dart.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/base/firecross_app.dart (Run flutter format to format lib/src/base/firecross_app.dart.)
  • lib/src/base/firecross_auth.dart (Run flutter format to format lib/src/base/firecross_auth.dart.)
  • lib/src/mobile/firecross_app.dart (Run flutter format to format lib/src/mobile/firecross_app.dart.)
  • lib/src/mobile/firecross_auth.dart (Run flutter format to format lib/src/mobile/firecross_auth.dart.)
  • lib/src/web/firecross_auth.dart (Run flutter format to format lib/src/web/firecross_auth.dart.)

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (firebase, firebase_auth).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and firecross.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-9 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
firebase ^6.0.0 6.0.0 7.3.0
firebase_auth ^0.14.0+5 0.14.0+9 0.16.1
firebase_core ^0.4.0+9 0.4.2+2 0.4.5
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
firebase_core_platform_interface 1.0.4
flutter 0.0.0
http 0.12.1
http_parser 3.1.4
js 0.6.2
matcher 0.12.8
meta 1.1.8
path 1.7.0
pedantic 1.9.0 1.9.1
plugin_platform_interface 1.0.2
quiver 2.1.3
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test