firebase_repository 1.0.54

Flutter plugins #

Build Status

This repo is a companion repo to the main flutter repo. It contains the source code for Flutter first-party plugins (i.e., plugins developed by the core Flutter team). Check the packages directory for all plugins.

Flutter plugins enable access to platform-specific APIs. For more information about plugins, and how to use them, see https://flutter.dev/platform-plugins/.

These plugins are also available on pub.

Issues #

Please file any issues, bugs, or feature requests in the main flutter repo.

Contributing #

If you wish to contribute a new plugin to the Flutter ecosystem, please see the documentation for developing packages and platform channels. You can store your plugin source code in any GitHub repository (the present repo is only intended for plugins developed by the core Flutter team). Once your plugin is ready you can publish to the pub repository.

If you wish to contribute a change to any of the existing plugins in this repo, please review our contribution guide, and send a pull request.

Plugins #

These are the available plugins in this repository.

PluginPub
android_alarm_managerpub package
android_intentpub package
batterypub package
camerapub package
connectivitypub package
device_infopub package
google_maps_flutterpub package
google_sign_inpub package
image_pickerpub package
in_app_purchasepub package
local_authpub package
package_infopub package
path_providerpub package
quick_actionspub package
sensorspub package
sharepub package
shared_preferencespub package
url_launcherpub package
video_playerpub package
webview_flutterpub package

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_repository: ^1.0.54

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_repository/firebase_repository.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
10
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Apr 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Fix lib/src/firebase_dispositivos_repository.dart. (-1 points)

Analysis of lib/src/firebase_dispositivos_repository.dart reported 2 hints:

line 91 col 8: The method doesn't override an inherited method.

line 95 col 10: This function has a return type of 'String', but doesn't end with a return statement.

Fix lib/src/entities/automatismo_programado_entity.dart. (-0.50 points)

Analysis of lib/src/entities/automatismo_programado_entity.dart reported 1 hint:

line 2 col 8: Unused import: 'package:flutter/material.dart'.

Fix lib/src/entities/profile_entity.dart. (-0.50 points)

Analysis of lib/src/entities/profile_entity.dart reported 1 hint:

line 4 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: ProfileEntity.uuid, ProfileEntity.nombre, ProfileEntity.apellido, ProfileEntity.activo, ProfileEntity.email, ProfileEntity.empresa, ProfileEntity.mixer, ProfileEntity.rol, ProfileEntity.suspended

Fix additional 50 files with analysis or formatting issues. (-2 points)

Additional issues in the following files:

  • lib/src/firebase_automatismos_programados_repository.dart (1 hint)
  • lib/src/firebase_razas_repository.dart (1 hint)
  • lib/src/firebase_terceros_repository.dart (1 hint)
  • lib/src/models/automatismo_programado.dart (1 hint)
  • lib/firebase_repository.dart (Run flutter format to format lib/firebase_repository.dart.)
  • lib/src/automatismos_programados_repository.dart (Run flutter format to format lib/src/automatismos_programados_repository.dart.)
  • lib/src/dispositivos_repository.dart (Run flutter format to format lib/src/dispositivos_repository.dart.)
  • lib/src/empresa_repository.dart (Run flutter format to format lib/src/empresa_repository.dart.)
  • lib/src/entities/caravana_entity.dart (Run flutter format to format lib/src/entities/caravana_entity.dart.)
  • lib/src/entities/carga_entity.dart (Run flutter format to format lib/src/entities/carga_entity.dart.)
  • lib/src/entities/categoria_entity.dart (Run flutter format to format lib/src/entities/categoria_entity.dart.)
  • lib/src/entities/categoria_sanitaria_entity.dart (Run flutter format to format lib/src/entities/categoria_sanitaria_entity.dart.)
  • lib/src/entities/corral_entity.dart (Run flutter format to format lib/src/entities/corral_entity.dart.)
  • lib/src/entities/descarga_entity.dart (Run flutter format to format lib/src/entities/descarga_entity.dart.)
  • lib/src/entities/dieta_entity.dart (Run flutter format to format lib/src/entities/dieta_entity.dart.)
  • lib/src/entities/dispositivo_entity.dart (Run flutter format to format lib/src/entities/dispositivo_entity.dart.)
  • lib/src/entities/entities.dart (Run flutter format to format lib/src/entities/entities.dart.)
  • lib/src/entities/mixer_entity.dart (Run flutter format to format lib/src/entities/mixer_entity.dart.)
  • lib/src/entities/pendiente_entity.dart (Run flutter format to format lib/src/entities/pendiente_entity.dart.)
  • lib/src/entities/producto_sanitario_entity.dart (Run flutter format to format lib/src/entities/producto_sanitario_entity.dart.)
  • lib/src/entities/raza_entity.dart (Run flutter format to format lib/src/entities/raza_entity.dart.)
  • lib/src/entities/tercero_entity.dart (Run flutter format to format lib/src/entities/tercero_entity.dart.)
  • lib/src/firebase_caravanas_repository.dart (Run flutter format to format lib/src/firebase_caravanas_repository.dart.)
  • lib/src/firebase_cargas_repository.dart (Run flutter format to format lib/src/firebase_cargas_repository.dart.)
  • lib/src/firebase_categorias_repository.dart (Run flutter format to format lib/src/firebase_categorias_repository.dart.)
  • lib/src/firebase_categorias_sanitarias_repository.dart (Run flutter format to format lib/src/firebase_categorias_sanitarias_repository.dart.)
  • lib/src/firebase_corrales_repository.dart (Run flutter format to format lib/src/firebase_corrales_repository.dart.)
  • lib/src/firebase_descargas_repository.dart (Run flutter format to format lib/src/firebase_descargas_repository.dart.)
  • lib/src/firebase_dietas_programadas_repository.dart (Run flutter format to format lib/src/firebase_dietas_programadas_repository.dart.)
  • lib/src/firebase_dietas_repository.dart (Run flutter format to format lib/src/firebase_dietas_repository.dart.)
  • lib/src/firebase_mixers_repository.dart (Run flutter format to format lib/src/firebase_mixers_repository.dart.)
  • lib/src/firebase_pendientes_repository.dart (Run flutter format to format lib/src/firebase_pendientes_repository.dart.)
  • lib/src/firebase_productos_repository.dart (Run flutter format to format lib/src/firebase_productos_repository.dart.)
  • lib/src/firebase_productos_sanitarios_repository.dart (Run flutter format to format lib/src/firebase_productos_sanitarios_repository.dart.)
  • lib/src/firebase_tropas_repository.dart (Run flutter format to format lib/src/firebase_tropas_repository.dart.)
  • lib/src/models/caravana.dart (Run flutter format to format lib/src/models/caravana.dart.)
  • lib/src/models/carga.dart (Run flutter format to format lib/src/models/carga.dart.)
  • lib/src/models/categoria_sanitaria.dart (Run flutter format to format lib/src/models/categoria_sanitaria.dart.)
  • lib/src/models/corral.dart (Run flutter format to format lib/src/models/corral.dart.)
  • lib/src/models/descarga.dart (Run flutter format to format lib/src/models/descarga.dart.)
  • lib/src/models/dieta.dart (Run flutter format to format lib/src/models/dieta.dart.)
  • lib/src/models/dieta_programada.dart (Run flutter format to format lib/src/models/dieta_programada.dart.)
  • lib/src/models/dispositivo.dart (Run flutter format to format lib/src/models/dispositivo.dart.)
  • lib/src/models/empresa.dart (Run flutter format to format lib/src/models/empresa.dart.)
  • lib/src/models/mixer.dart (Run flutter format to format lib/src/models/mixer.dart.)
  • lib/src/models/pendiente.dart (Run flutter format to format lib/src/models/pendiente.dart.)
  • lib/src/models/producto.dart (Run flutter format to format lib/src/models/producto.dart.)
  • lib/src/models/producto_sanitario.dart (Run flutter format to format lib/src/models/producto_sanitario.dart.)
  • lib/src/models/raza.dart (Run flutter format to format lib/src/models/raza.dart.)
  • lib/src/models/tropa.dart (Run flutter format to format lib/src/models/tropa.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-40 points)

The version constraint in pubspec.yaml does not support the latest published versions for 4 dependencies (cloud_firestore, equatable, intl, rxdart).

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and firebase_repository.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
cloud_firestore ^0.12.9+4 0.12.11 0.13.4+2
equatable ^0.3.0 0.3.0 1.1.1
firebase_core ^0.4.0+7 0.4.4+3
flutter 0.0.0
flutter_bluetooth_serial_caravanas ^0.2.13 0.2.13
intl ^0.15.8 0.15.8 0.16.1
meta ^1.1.8 1.1.8
rxdart ^0.22.0 0.22.6 0.23.1
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.11 1.14.12
firebase 7.3.0
firebase_core_platform_interface 1.0.4
firebase_core_web 0.1.1+2
flutter_web_plugins 0.0.0
http 0.12.0+4
http_parser 3.1.4
js 0.6.1+1
matcher 0.12.6
path 1.6.4
pedantic 1.9.0
plugin_platform_interface 1.0.2
quiver 2.1.3
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8