firebase_list 1.0.1

FirebaseList #

A Dart List class synchronized to a Firebase reference

Running tests pub run test --platform chrome

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_list: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_list/firebase_list.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
15
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
54
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

We analyzed this package on May 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.1
  • pana: 0.13.8-dev

Health suggestions

Fix lib/firebase_list.dart. (-9.99 points)

Analysis of lib/firebase_list.dart reported 21 hints, including:

line 32 col 1: Prefer using /// for doc comments.

line 48 col 55: Unnecessary new keyword.

line 49 col 57: Unnecessary new keyword.

line 50 col 53: Unnecessary new keyword.

line 57 col 16: Don't type annotate initializing formals.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Documentation URL doesn't exist. (-10 points)

At the time of the analysis the documentation field http://sirctseb.github.io/FirebaseList was unreachable.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and firebase_list.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-6 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
collection ^1.14.12 1.14.12
firebase >=7.0.0 <8.0.0 7.3.0
Transitive dependencies
charcode 1.1.3
http 0.12.1
http_parser 3.1.4
js 0.6.1+1
meta 1.1.8
path 1.7.0
pedantic 1.9.0
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
logging ^0.11.2
test ^1.14.2