fints_client 0.0.1

  • Readme
  • Changelog
  • Installing
  • 40

Build Status

fints_client #

A dart based FinTS Client, used for multibanking applications

Getting Started #


[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  fints_client: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:fints_client/fints_client.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1

Health suggestions

Fix lib/fints_client.dart. (-1.49 points)

Analysis of lib/fints_client.dart reported 3 hints:

line 9 col 10: The value of the field '_errorMsg' isn't used.

line 10 col 7: The value of the field '_productId' isn't used.

line 11 col 7: The value of the field '_version' isn't used.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (iban).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and fints_client.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
http ^0.12.0+2 0.12.1
iban ^0.1.1 0.1.1 0.2.0
validators ^2.0.0+1 2.0.1
Transitive dependencies
asn1lib 0.6.5
basic_utils 2.5.4
charcode 1.1.3
collection 1.14.13
convert 2.1.1
crypto 2.1.5
http_parser 3.1.4
intl 0.16.1
json_annotation 3.0.1
logging 0.11.4
meta 1.1.8 1.2.0
mod97 0.1.0
path 1.7.0
pedantic 1.9.0 1.9.1
pointycastle 1.0.2
random_string 2.1.0
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0
vin_decoder 0.1.2
Dev dependencies
test ^1.3.0