fingerprintjs 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • new60

Dart FingerprintJS #

FingerprintJS wrapper for Dart

Getting Started #

pub package

Add script in index.html before importing main.dart.js:

<script src="//cdnjs.cloudflare.com/ajax/libs/fingerprintjs2/2.1.0/fingerprint2.min.js"></script>

Usage #

import 'package:fingerprintjs/fingerprint.dart';

String fingerprint = await Fingerprint.getHash();

Issues and feedback #

Please file issues to send feedback or report a bug.

1.0.0 #

  • Add get with options
  • Add x64hash128

0.0.3 #

  • Update readme

0.0.2 #

  • Update readme

0.0.1 #

  • Initial version

example/README.md

void main() async {
  String = await Fingerprint.getHash();
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fingerprintjs: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fingerprintjs/fingerprintjs.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
20
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14

Analysis suggestions

Package not compatible with runtime flutter-native on android

Because:

  • package:fingerprintjs/fingerprintjs.dart that imports:
  • package:js/js.dart that imports:
  • dart:js

Package not compatible with runtime flutter-native on ios

Because:

  • package:fingerprintjs/fingerprintjs.dart that imports:
  • package:js/js.dart that imports:
  • dart:js

Package not compatible with runtime flutter-native on linux

Because:

  • package:fingerprintjs/fingerprintjs.dart that imports:
  • package:js/js.dart that imports:
  • dart:js

Package not compatible with runtime flutter-native on macos

Because:

  • package:fingerprintjs/fingerprintjs.dart that imports:
  • package:js/js.dart that imports:
  • dart:js

Package not compatible with runtime flutter-native on windows

Because:

  • package:fingerprintjs/fingerprintjs.dart that imports:
  • package:js/js.dart that imports:
  • dart:js

Package not compatible with runtime native

Because:

  • package:fingerprintjs/fingerprintjs.dart that imports:
  • package:js/js.dart that imports:
  • dart:js

Package not compatible with runtime native-aot

Because:

  • package:fingerprintjs/fingerprintjs.dart that imports:
  • package:js/js.dart that imports:
  • dart:js

Health issues and suggestions

Document public APIs. (-1 points)

35 out of 35 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
js ^0.6.2 0.6.2
Dev dependencies
build_runner ^1.2.0
build_web_compilers ^2.9.0