file_selector 0.9.2 icon indicating copy to clipboard operation
file_selector: ^0.9.2 copied to clipboard

Flutter plugin for opening and saving files, or selecting directories, using native file selection UI.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add file_selector

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  file_selector: ^0.9.2

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:file_selector/file_selector.dart';
141
likes
140
pub points
97%
popularity

Publisher

verified publisher iconflutter.dev

Flutter plugin for opening and saving files, or selecting directories, using native file selection UI.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

file_selector_ios, file_selector_linux, file_selector_macos, file_selector_platform_interface, file_selector_web, file_selector_windows, flutter

More

Packages that depend on file_selector