file 5.2.1

Dart native
Flutter Android iOS

A pluggable, mockable file system abstraction for Dart. Supports local file system access, as well as in-memory file systems, record-replay file systems, and chroot file systems.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  file: ^5.2.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:file/file.dart';
48
likes
100
pub points
100%
popularity

A pluggable, mockable file system abstraction for Dart. Supports local file system access, as well as in-memory file systems, record-replay file systems, and chroot file systems.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

yjbanov@google.com
tvolkert@google.com
pquitslund@google.com
jonahwilliams@google.com
decafmatan@gmail.com

License

BSD (LICENSE)

Dependencies

intl, meta, path

More

Packages that depend on file