ferry_flutter 0.1.0+1

  • Readme
  • Changelog
  • Installing
  • 69

MIT License PRs Welcome Watch on GitHub Star on GitHub Watch on GitHub Discord

Flutter widgets for executing GraphQL operations using the ferry client.

NOTE: you may not need these widgets to work with ferry in Flutter. They are actually just thin wrappers around Flutter's StreamBuilder widget.

Changelog #

All notable changes to this project will be documented in this file.

The format is based on Keep a Changelog, and this project adheres to Semantic Versioning.

[Unreleased] #

[0.1.0+1] - 2020-06-09 #

Updated #

  • bump versions

[0.1.0] - 2020-05-10 #

Added #

  • initial release as an independent package

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ferry_flutter: ^0.1.0+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ferry_flutter/ferry_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
48
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
74
Overall:
Weighted score of the above. [more]
69
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • ferry_flutter that is a package requiring null.

Maintenance suggestions

The package description is too short. (-16 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and ferry_flutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
ferry ^0.4.0 0.4.1
flutter 0.0.0
flutter_test 0.0.0
gql_exec ^0.2.4 0.2.4 0.2.5-alpha+1590789520957
Transitive dependencies
archive 2.0.13
args 1.6.0
async 2.4.1 2.4.2
boolean_selector 2.0.0
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.4 2.1.5
ferry_cache 0.1.1
ferry_store 0.1.0
gql 0.12.3 0.12.4-alpha+1590789520945
gql_link 0.3.0 0.3.1-alpha+1590789520964
image 2.1.12 2.1.14
matcher 0.12.6 0.12.8
meta 1.1.8 1.2.1
normalize 0.2.1
path 1.6.4 1.7.0
petitparser 2.4.0 3.0.4
quiver 2.1.3
rxdart 0.24.1
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.3 1.9.5
stream_channel 2.0.0
string_scanner 1.0.5
term_glyph 1.1.0
test_api 0.2.15 0.2.17
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
xml 3.6.1 4.2.0
Dev dependencies
mockito ^4.1.1
test ^1.9.4