fengari_lua 1.1.0

  • Readme
  • Changelog
  • Installing
  • 49

fengari-lua: Dart bindings for fengari-web, a Lua 5.3 interpreter. #

Installation #

  1. Add the fengari_lua package to your pubspec:
dependencies:
  fengari_lua: ^1.1.0
  1. Add fengari-web.js to your html:
<head>
    ...
    <script src="https://github.com/fengari-lua/fengari-web/releases/download/v0.1.4/fengari-web.js"></script>
</head>

Usage #

This library comes with bindings for most of the Lua API, see https://www.lua.org/manual/5.3/

It also includes a wrapper which greatly simplifies interaction with Lua states, Example:

import 'package:fengari_lua/lua.dart';
main() {
  var state = LuaState();
  state.loadString("""
    print("Hello, World!")
  """);
  state.call();
  state.close();
}

1.1.0 #

  • Fixed several bugs in fengari bindings.
  • Added fengari-interop library.
  • Added many more methods to LuaState, including the ability to load modules.

1.0.0-hotfix.1 #

  • Added CHANGELOG.md.
  • Added README.md to lua_repl example.
  • Added screenshot to lua_repl example.

1.0.0 #

  • First release!
  • Implements entire fengari-web v0.1.4 Lua bindings.
  • Implements LuaState wrapper for simplifying interaction with Lua states.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fengari_lua: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fengari_lua/fengari.dart';
import 'package:fengari_lua/lua.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
96
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1

Analysis suggestions

Package not compatible with runtime flutter-native of android

Because of the import of dart:js via the import chain package:fengari_lua/fengari.dart->package:js/js.dart->dart:js

Package not compatible with runtime flutter-native of ios

Because of the import of dart:js via the import chain package:fengari_lua/fengari.dart->package:js/js.dart->dart:js

Package not compatible with runtime flutter-native of linux

Because of the import of dart:js via the import chain package:fengari_lua/fengari.dart->package:js/js.dart->dart:js

Package not compatible with runtime flutter-native of macos

Because of the import of dart:js via the import chain package:fengari_lua/fengari.dart->package:js/js.dart->dart:js

Package not compatible with runtime flutter-native of windows

Because of the import of dart:js via the import chain package:fengari_lua/fengari.dart->package:js/js.dart->dart:js

Package not compatible with runtime native-aot

Because of the import of dart:js via the import chain package:fengari_lua/fengari.dart->package:js/js.dart->dart:js

Package not compatible with runtime native-jit

Because of the import of dart:js via the import chain package:fengari_lua/fengari.dart->package:js/js.dart->dart:js

Health suggestions

Format lib/fengari.dart.

Run dartfmt to format lib/fengari.dart.

Format lib/lua.dart.

Run dartfmt to format lib/lua.dart.

Maintenance suggestions

Package is getting outdated. (-3.56 points)

The package was last published 54 weeks ago.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and fengari_lua.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
js ^0.6.0 0.6.2
quiver >=2.0.0 <3.0.0 2.1.3
Transitive dependencies
matcher 0.12.8
meta 1.1.8 1.2.0
path 1.7.0
stack_trace 1.9.5
Dev dependencies
pedantic ^1.7.0
test ^1.6.4