feedparser 0.0.2

feedparser #

pub package Build Status

A Dart library for parsing RSS feeds.

Usage #

import 'package:feedparser/feedparser.dart';

void main() {
  Feed feed = parse(r'''
    <?xml version="1.0" encoding="UTF-8"?>
    <rss version="2.0">
      <channel>
        <title>Hello World!</title>      
        <description>Parse RSS feeds in Dart with feedparser</description>
      </channel>
    </rss>
  ''');

  print(feed);

  // Output:
  //    title: Hello World!
  //    link: null
  //    description: Parse RSS feeds in Dart with feedparser
  //    language: null
  //    copyright: null
  //    pubDate: null
  //    lastBuildDate: null
  //    image: null
  //    items: []
}

Strict mode #

As long as the input string provided is a valid XML string, feedparser will attempt to parse it and return a Feed object. In strict mode feedparser instead throws ArgumentErrors for missing mandatory fields [as defined by the RSS 2.0 spec]. This is useful for testing feeds to ensure they meet the spec, but impractical when dealing with feeds not under your control.

  Feed feed = parse(xmlString, strict: true);

0.0.2 #

  • Add optional 'comments' field to FeedItem

0.0.1 #

  • Initial version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  feedparser: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:feedparser/feedparser.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
74
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
37
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.21.0 <2.0.0