feather 0.2.0

  • Readme
  • Changelog
  • Installing
  • 57

Feather #

A flutter utility library with re-frame esk features and miscellaneous functions

[0.2.0] - Package Upgrade

Upgrade packages and support Dart 2.0.0-dev < 3.0.0


[0.1.0] - Minor Release

Feather has proven stable enough for a minor release


  • Issue with setting the initial AppDb state.

[0.0.6] - Or->ifVal

Renamed or to ifVal

[0.0.5] - Null Checks

Adds isNull and isNotNull

[0.0.4] - Conditional Functions

Adds support for when and or functions with lazyish evaluation

[0.0.3] - Casting Functions

Adds typecasting functionality for List

  • Map with asMaps
  • Widget with asWidgets
  • nonNullMaps
  • nonNullWidgets

Fixed some Dart 2 assertion checks.

[0.0.2] - Merge Function

Adds functionality for:

  • Utilities
    • merge

[0.0.1] - Initial Release

Provides functionality for:

  • Flow
    • AppDb
    • AppDbStream Stream View
  • Utilities
    • get/getIn
    • set/setIn
    • remove/removeIn
    • removeNulls
    • contains

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  feather: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:feather/feather.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (rxdart).

Package is getting outdated. (-37.26 points)

The package was last published 71 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and feather.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
flutter 0.0.0
flutter_stream_friends ^0.8.0 0.8.0
rxdart ^0.18.1 0.18.1 0.23.1
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies