A flutter utility library with re-frame esk features and miscellaneous functions
[0.2.0] - Package Upgrade
Upgrade packages and support Dart 2.0.0-dev < 3.0.0
[0.1.0] - Minor Release
Feather has proven stable enough for a minor release
- Issue with setting the initial AppDb state.
[0.0.6] - Or->ifVal
[0.0.5] - Null Checks
[0.0.4] - Conditional Functions
Adds support for
or functions with lazyish evaluation
[0.0.3] - Casting Functions
Adds typecasting functionality for List
- Map with
- Widget with
Fixed some Dart 2 assertion checks.
[0.0.2] - Merge Function
Adds functionality for:
[0.0.1] - Initial Release
Provides functionality for:
- AppDbStream Stream View
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: feather: ^0.2.0
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.5.1
- pana: 0.12.21
- Flutter: 1.9.1+hotfix.4
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
Maintenance issues and suggestions
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (
Package is getting outdated. (-11.51 points)
The package was last published 58 weeks ago.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
feather.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
The package description is too short. (-8 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
|Dart SDK||>=2.0.0-dev <3.0.0|