fcore 0.0.6

  • Readme
  • Changelog
  • Example
  • Installing
  • 38

fcore #

Scliang Flutter Plugin(contain: SinPoints、LoopBanner)

Getting Started #

Usage

To use this plugin, add fcore as a dependency in your pubspec.yaml file.

dependencies:
  fcore: ^0.0.6

In your .dart file.

import 'package:fcore/fcore.dart';
import 'package:fcore/ui/sin_points.dart';
import 'package:fcore/ui/loop_banner.dart';

Example - SinPoints

MaterialButton(
  onPressed: (){
    setState((){
      _running ^= true;
    });
  },
  child: SizedBox(
    width: 160,
    height: 160,
    child: SinPoints(
      running: _running,
    ),
  ),
)

Example - LoopBanner

Center(
  child: LoopBanner(
    duration: Duration(seconds: 3),
    itemCount: 6,
    itemBuilder: (context, position){
      return Card(
        color: position % 3 == 0 ? Color(0xff33b5e5) : 
               position % 3 == 1 ? Color(0xffdd4400) : 
                                   Color(0xff44cc00),
        child: MaterialButton(
          onPressed: (){},
          child: Center(
            child: Text('${position + 1}',
              style: TextStyle(
                color: Colors.white,
                fontSize: 40,
              ),
            ),
          ),
        ),
      );
    },
  ),
)

Other #

This project is a starting point for a Flutter
[plug-in package](https://flutter.io/developing-packages/),
a specialized package that includes platform-specific implementation code for
Android and/or iOS.

For help getting started with Flutter, view our 
[online documentation](https://flutter.io/docs), which offers tutorials, 
samples, guidance on mobile development, and a full API reference.

v0.0.6 #

  • Update sin points.
  • remove bgColor.

v0.0.5 #

  • Add auto-scroll to loop banner widget.

v0.0.4 #

  • Append loop banner widget.

v0.0.3 #

  • Append sin point animation widget.

v0.0.2 #

  • Update License.

v0.0.1 #

  • Init, Append publish.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:fcore/fcore.dart';
import 'package:fcore/ui/sin_points.dart';
// import 'package:fcore/ui/loop_banner.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';
  bool _running = false;

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await Fcore.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      theme: ThemeData(
        primaryColor: Colors.white,
      ),
      home: Scaffold(
        appBar: AppBar(
          title: Text('Plugin Running on: $_platformVersion'),
        ),
        body: Center(
          child: MaterialButton(
            padding: EdgeInsets.all(0),
            onPressed: (){
              setState((){
                _running ^= true;
              });
            },
            child: SizedBox(
              width: 160,
              height: 160,
              child: SinPoints(
                running: _running,
              ),
            ),
          ),
        ),
        // body: Center(
        //   child: LoopBanner(
        //     duration: Duration(milliseconds: 2000),
        //     itemCount: 6,
        //     itemBuilder: (context, position){
        //       return Card(
        //         color: position % 3 == 0 ? Color(0xff33b5e5) : 
        //           position % 3 == 1 ? Color(0xffdd4400) : 
        //           Color(0xff44cc00),
        //         child: MaterialButton(
        //           onPressed: (){},
        //           child: Center(
        //             child: Text('${position + 1}',
        //               style: TextStyle(
        //                 color: Colors.white,
        //                 fontSize: 40,
        //               ),
        //             ),
        //           ),
        //         ),
        //       );
        //     },
        //   ),
        // ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fcore: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fcore/fcore.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
38
Learn more about scoring.

We analyzed this package on Apr 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Format lib/fcore.dart.

Run flutter format to format lib/fcore.dart.

Format lib/ui/loop_banner.dart.

Run flutter format to format lib/ui/loop_banner.dart.

Format lib/ui/sin_points.dart.

Run flutter format to format lib/ui/sin_points.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/Scliang/fcore.git was unreachable.

Package is getting outdated. (-22.74 points)

The package was last published 64 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-7 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8