fast_ui 0.1.2 copy "fast_ui: ^0.1.2" to clipboard
fast_ui: ^0.1.2 copied to clipboard

A collection of Flutter packages aimed to make UI development faster

fast_ui is a collection of Flutter packages aimed to make UI development faster

pub package codecov checks popularity likes pub points

Packages #

Package Description
fast_rx_flutter Reactive state management
fast_rx_persistence Interface for creating key/value store persistence for Rx values
fast_nav Contextless navigation
fast_overlays Contextless overlays (snackbars, dialogs, etc.)
fast_extensions Convenience extensions

Add-on Packages #

These package come with additional dependencies

Package Description
fast_rx_shared_preferences Implementation of fast_rx_persistence for use with Shared Preferences

About #

What fast_ui is:

  • Modular
  • Easy to understand
  • Well documented
  • Thoroughly tested

What fast_ui is not:

  • Magic
  • An excuse to write bad code
  • A custom implementation of existing Flutter functionality

Hosted example project

Getting started #

There are two options to use fast_ui:

  • Add fast_ui to your pubspec.yaml to include all the default packages
  • Add only the desired packages to your pubspec.yaml

Usage #

See the individual package readmes for usage instructions

Additional information #

Pull requests welcome

20
likes
140
pub points
58%
popularity

Publisher

verified publisherrexios.dev

A collection of Flutter packages aimed to make UI development faster

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

fast_extensions, fast_nav, fast_overlays, fast_rx_flutter, fast_rx_persistence, flutter

More

Packages that depend on fast_ui