fast_ui 0.1.0 copy "fast_ui: ^0.1.0" to clipboard
fast_ui: ^0.1.0 copied to clipboard

outdated

A collection of Flutter packages aimed to make UI development faster

fast_ui is a collection of Flutter packages aimed to make UI development faster

pub package codecov checks popularity likes pub points

Features #

Package Description
fast_rx Reactive state management
fast_nav Contextless navigation
fast_overlays Contextless overlays (snackbars, dialogs, etc.)
fast_extensions Convenience extensions

For service location, I recommend GetIt

What fast_ui is:

  • Modular
  • Easy to understand
  • Well documented
  • Thoroughly tested

What fast_ui is not:

  • Magic
  • An excuse to write bad code
  • A custom implementation of existing Flutter functionality

Hosted example project

Getting started #

There are two options to use fast_ui:

  • Add fast_ui to your pubspec.yaml to include all the packages
  • Add only the desired packages to your pubspec.yaml

Usage #

See the individual package readmes for usage instructions

Additional information #

Pull requests welcome

20
likes
0
pub points
58%
popularity

Publisher

verified publisherrexios.dev

A collection of Flutter packages aimed to make UI development faster

Homepage
Repository (GitHub)
View/report issues

License

unknown (LICENSE)

Dependencies

fast_extensions, fast_nav, fast_overlays, fast_rx, flutter

More

Packages that depend on fast_ui