fart_scroll 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 33

fart_scroll #

You want fart noises as you scroll? I've got you covered.

Everyone farts. And now your apps* can too.

Heavily inspired by fartscroll.js

How to use #

Simply mixin FartScrollMixin with your State and pass fartScrollController to a widget which takes a ScrollController.

class _HomePageState extends State<HomePage> with FartScrollMixin<HomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('Home'),
      ),
      body: ListView.builder(
          controller: fartScrollController,
          itemCount: 500,
          itemBuilder: (_, index) {
            return ListTile(title: Text("Item $index"));
          }),
    );
  }
}

[1.0.0] - 12/23/2018 #

  • Initial fart. 💨

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:fart_scroll/fart_scroll.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'fart_scroll Demo',
      theme: ThemeData(
        primarySwatch: Colors.pink,
      ),
      routes: {
        '/': (context) => HomePage(),
      },
    );
  }
}

class HomePage extends StatefulWidget {
  @override
  _HomePageState createState() {
    return _HomePageState();
  }
}

class _HomePageState extends State<HomePage> with FartScrollMixin<HomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('fart_scroll Demo'),
      ),
      body: ListView.builder(
          controller: fartScrollController,
          itemCount: 500,
          itemBuilder: (_, index) {
            return ListTile(title: Text("Item $index"));
          }),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fart_scroll: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fart_scroll/fart_scroll.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
17
Overall:
Weighted score of the above. [more]
33
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:fart_scroll/fart_scroll.dart, package:path_provider/path_provider.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:fart_scroll/fart_scroll.dart, package:path_provider/path_provider.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:fart_scroll/fart_scroll.dart, package:path_provider/path_provider.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:fart_scroll/fart_scroll.dart, package:path_provider/path_provider.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [fart_scroll] that is in a package requiring null.

Health suggestions

Fix lib/fart_scroll.dart. (-0.50 points)

Analysis of lib/fart_scroll.dart reported 1 hint:

line 57 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (audioplayers).

Package is getting outdated. (-52.60 points)

The package was last published 79 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
audioplayers ^0.7.8 0.7.8 0.15.1
flutter 0.0.0
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
meta 1.1.8
path_provider 0.4.1 1.6.11
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
uuid 1.0.3 2.2.0
vector_math 2.0.8
Dev dependencies
flutter_test