fart_scroll 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 44

fart_scroll #

You want fart noises as you scroll? I've got you covered.

Everyone farts. And now your apps* can too.

Heavily inspired by fartscroll.js

How to use #

Simply mixin FartScrollMixin with your State and pass fartScrollController to a widget which takes a ScrollController.

class _HomePageState extends State<HomePage> with FartScrollMixin<HomePage> {
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('Home'),
      body: ListView.builder(
          controller: fartScrollController,
          itemCount: 500,
          itemBuilder: (_, index) {
            return ListTile(title: Text("Item $index"));

[1.0.0] - 12/23/2018

  • Initial fart. 💨


example #

Example app of fart_scroll package.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  fart_scroll: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:fart_scroll/fart_scroll.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Health suggestions

Fix lib/fart_scroll.dart. (-0.50 points)

Analysis of lib/fart_scroll.dart reported 1 hint:

line 57 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (audioplayers).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
audioplayers ^0.7.8 0.7.8 0.13.5
flutter 0.0.0
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.4
meta 1.1.7 1.1.8
path_provider 0.4.1 1.5.1
sky_engine 0.0.99
typed_data 1.1.6
uuid 1.0.3 2.0.4
vector_math 2.0.8
Dev dependencies