fake_weibo 0.2.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 73

fake_weibo #

Build Status Codecov GitHub Tag Pub Package License

flutter版新浪微博SDK

fake 系列 libraries #

dart/flutter 私服 #

docs #

android #

# 不需要做任何额外接入工作
# 混淆已打入 Library,随 Library 引用,自动添加到 apk 打包混淆

ios #

在Xcode中,选择你的工程设置项,选中“TARGETS”一栏,在“info”标签栏的“URL type“添加“URL scheme”为你所注册的应用程序id

URL Types
weibosdk: identifier=com.weibo schemes=wb${appKey}
iOS 9系统策略更新,限制了http协议的访问,此外应用需要在“Info.plist”中将要使用的URL Schemes列为白名单,才可正常检查其他应用是否安装。
<key>LSApplicationQueriesSchemes</key>
<array>
    <string>sinaweibo</string>
    <string>sinaweibohd</string>
    <string>weibosdk</string>
    <string>weibosdk2.5</string>
</array>
<key>NSAppTransportSecurity</key>
<dict>
    <key>NSAllowsArbitraryLoads</key>
    <true/>
    <key>NSExceptionDomains</key>
    <dict>
        <key>sina.com.cn</key>
        <dict>
            <key>NSIncludesSubdomains</key>
            <true/>
            <key>NSThirdPartyExceptionAllowsInsecureHTTPLoads</key>
            <true/>
            <key>NSExceptionMinimumTLSVersion</key>
            <string>TLSv1.0</string>
            <key>NSThirdPartyExceptionRequiresForwardSecrecy</key>
            <false/>
        </dict>
    </dict>
</dict>

flutter #

  • snapshot
dependencies:
  fake_weibo:
    git:
      url: https://github.com/v7lin/fake_weibo.git
  • release
dependencies:
  fake_weibo: ^${latestTag}
  • example

示例

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.2.1] - 2019.5.29

  • 添加大图分享
  • 添加图文分享

[0.2.0] - 2019.5.24

  • 优化
  • 自动化发布

[0.1.0] - 2019.3.19

  • 规范 library 代码

[0.0.1] - 2019.3.5

  • android/ios weibo

example/README.md

fake_weibo_example #

Demonstrates how to use the fake_weibo plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fake_weibo: ^0.2.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fake_weibo/fake_weibo.dart';
  
Version Uploaded Documentation Archive
0.2.1 May 29, 2019 Go to the documentation of fake_weibo 0.2.1 Download fake_weibo 0.2.1 archive
0.2.0 May 24, 2019 Go to the documentation of fake_weibo 0.2.0 Download fake_weibo 0.2.0 archive
0.1.0 Mar 20, 2019 Go to the documentation of fake_weibo 0.1.0 Download fake_weibo 0.1.0 archive
0.0.1+1 Mar 7, 2019 Go to the documentation of fake_weibo 0.0.1+1 Download fake_weibo 0.0.1+1 archive
0.0.1 Mar 5, 2019 Go to the documentation of fake_weibo 0.0.1 Download fake_weibo 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
54
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on Jun 12, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.17
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
jaguar_serializer >=2.2.12 <3.0.0 2.2.12
meta >=1.1.6 <2.0.0 1.1.6 1.1.7
Transitive dependencies
collection 1.14.11
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
build_runner any
flutter_test
jaguar_serializer_cli any
pedantic >=1.4.0 <3.0.0