fake_http 0.0.1+4

  • Readme
  • Changelog
  • Installing
  • 23

fake_http #

GitHub tag pub package

flutter版okhttp3

fake 系列 libraries #

  1. flutter版okhttp3
  2. flutter版微信SDK
  3. flutter版腾讯(QQ)SDK
  4. flutter版新浪微博SDK
  5. flutter版支付宝SDK

dart/flutter 私服 #

simple_pub_server

OkHttpClient #

还是原来的配方,还是熟悉的味道

flutter #

snapshot #

dependencies:
  fake_http:
    git:
      url: https://github.com/v7lin/fake_http.git

release #

latestVersion = 0.0.1+3
dependencies:
  fake_http: ^${latestVersion}

example #

示例

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - 2018.9.30

  • 实现flutter版okhttp3

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fake_http: ^0.0.1+4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fake_http/fake_http.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
46
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
23
Learn more about scoring.

This package is not analyzed, because it is discontinued.

Health issues and suggestions

Document public APIs. (-0.27 points)

505 out of 518 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0