expressjs_interop 0.0.3

Interop library for ExpressJS #

Build Status Pub

Provides Dart bindings for Express framework JavaScript API.

This package is not actively maintained.

Note that this library does not provide support for handling object and function conversions between Dart and JS. You have to follow package js rules as described in its docs.

Example #

Checkout example/ folder to see it in action. To build and run:

$ # 1. Install node dependencies.
$ cd example/
$ npm install
$ cd ../
$
$ # 2. Build the app.
$ pub build example/
$
$ # 3. Run the app.
$ node build/example/index.dart.js

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.0.3 #

  • Prepare for Dart 2 stable.

0.0.2 #

  • Upgraded to node_interop: 0.1.0-beta.3.
  • Updated bindings and documentation
  • Removed Dart wrappers leaving this library JS-only (bindings-only) for now.

0.0.1 #

  • Initial version, created by Stagehand

example/main.dart

import 'package:expressjs_interop/expressjs_interop.dart';
import 'package:js/js.dart';
import 'package:node_interop/util.dart';
import 'package:node_interop/node.dart';

void main() {
  ExpressFunction express = require('express');
  var app = express();
  app.get('/', allowInterop((Request req, Response res, NextFunction next) {
    print('Request received: ${req.url}');
    res.send(jsify({"result": "OK"}));
  }));
  app.listen(8080);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  expressjs_interop: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:expressjs_interop/expressjs_interop.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
21
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
62
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Sep 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21

Platforms

Detected platforms: web, other

Primary library: package:expressjs_interop/expressjs_interop.dart with components: js.

Health suggestions

Format lib/expressjs_interop.dart.

Run dartfmt to format lib/expressjs_interop.dart.

Maintenance suggestions

Package is getting outdated. (-14.25 points)

The package was last published 59 weeks ago.

The package description is too short. (-14 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
js ^0.6.1 0.6.1+1
node_http ^1.0.0-dev 1.0.0
node_interop ^1.0.0-dev 1.0.3
Transitive dependencies
async 2.3.0
charcode 1.1.2
collection 1.14.12
http 0.12.0+2
http_parser 3.1.3
meta 1.1.7
node_io 1.0.1+2
path 1.6.4
pedantic 1.8.0+1
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
build_node_compilers ^0.1.8
build_runner ^0.9.1
build_test any
test ^1.0.0