explosion_animation 1.0.2

Explode Animation #

A Flutter package to create widgets with exploding animation. Currently two types of animations are supported. More will be added in future. Pull Requests are welcome.

Installation #

First, add explosion_animation as a dependency in your pubspec.yaml file.

No configuration required - the plugin should work out of the box.

Demo #

Animation Type Spread

Credits #

Vikram Pratap Singh

###

[1.0.2] - updated README.md

[1.0.1] - Added example code

[1.0.0] - Initial Version

example/README.md

Example #

import 'package:exlosion_animation/exlosion_animation.dart';
import 'package:image_picker/image_picker.dart';

var key = Explode.getKey();
class MyHomePage extends StatefulWidget {
  @override
  _MyHomePageState createState() => _MyHomePageState();
}
class _MyHomePageState extends State<MyHomePage> {
  String _imagePath;

  Future getImage() async {
    var image = await ImagePicker.pickImage(source: ImageSource.gallery);
    setState(() {
      _imagePath = image.path;
    });
  }

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: Center(
        child: Explode(
                      key: key,
                      size: Size(300, 300),
                      fit: BoxFit.cover,
                      particleCount: 200,
                      path: _imagePath,
                      type: ExplodeType.Spread,
                      isAsset: false,
                    ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  explosion_animation: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:explosion_animation/explosion_animation.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
16
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Jul 19, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/explosion_animation.dart.

Run flutter format to format lib/explosion_animation.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (palette_generator).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
palette_generator ^0.1.1 0.1.1 0.2.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
path 1.6.2
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin