expected_output 1.2.2

Dart native

Easily write and test multiline input and expected output, and avoid test case data clutter in your test logic.

1.2.2 #

  • Improved package description and added an example.
  • Internal code health improvements.

1.2.1 #

  • Set max SDK version to <3.0.0, and adjusted other dependencies.

1.2.0 #

  • Add support for front matter.

1.1.0 #

  • Add test helpers testDataCases and testDataCasesUnder.

1.0.0 #

  • Initial release, includes all functionality found in the README.
0
likes
100
pub points
32%
popularity

Easily write and test multiline input and expected output, and avoid test case data clutter in your test logic.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

srawlins@google.com

License

BSD (LICENSE)

Dependencies

path, pedantic, test

More

Packages that depend on expected_output