event_base 0.0.1
event_base: ^0.0.1 copied to clipboard

A event-driven library for flutter application

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add event_base

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  event_base: ^0.0.1

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:event_base/event_model.dart';
import 'package:event_base/event_utils.dart';
import 'package:event_base/id_generator.dart';
import 'package:event_base/image_pool.dart';
import 'package:event_base/name_generator.dart';
import 'package:event_base/object_utils.dart';
0
likes
70
pub points
0%
popularity

A event-driven library for flutter application

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on event_base