esptouch_flutter 0.2.4
esptouch_flutter: ^0.2.4 copied to clipboard

Flutter Android iOS

Flutter plugin for ESP-Touch to configure network for ESP-8266 and ESP-32 devices. Runs on iOS and Android.

0.2.4 #

Remove deprecated pubspec keys.

0.2.3 #

Reduce noisy logging

0.2.2 #

Remove EspTouchDemo-Info.plist. No idea why it was there but it breaks my build 🤬 README improvements in 0.2.2+1.

0.2.1 #

README: Add simple example with Kotlin

0.2.0 #

Migrated to AndroidX.

Change compileSdkVersion to 28. Fix #3: flutter build apk should now work again.

0.1.5 #

Fix podspecs for iOS.

0.1.4 #

Request run-time permissions for location on Android M+ to make BSSID/SSID information work. Execute event sink methods on the main thread.

0.1.3 #

Add example app screenshots.

0.1.2 #

More docs improvements. Add missing license.

0.1.1 #

Improve documentation.

0.1.0 #

Initial release. Support ESP-Touch on iOS and Android. Fully configurable from your Dart code.

24
likes
100
pub points
78%
popularity

Flutter plugin for ESP-Touch to configure network for ESP-8266 and ESP-32 devices. Runs on iOS and Android.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

vince.varga@smaho.com
vince.varga@serialdeveloper.com

License

MIT (LICENSE)

Dependencies

flutter, meta

More

Packages that depend on esptouch_flutter