er_firestore 1.0.1+4

  • Readme
  • Changelog
  • Example
  • Installing
  • new64

er_firestore #

Firestore Flutter Plugin #

Build Status

FlutterFire is a set of Flutter plugins that enable Flutter apps to use one or more Firebase services. You can follow an example that shows how to use these plugins in the Firebase for Flutter codelab.

Flutter is Google's mobile app SDK for crafting high-quality native interfaces on iOS and Android in record time. Flutter works with existing code, is used by developers and organizations around the world, and is free and open source.

Note: FlutterFire plugins are still under development, and some APIs might not be available yet. Feedback and Pull Requests are most welcome!

Available FlutterFire plugins #

PluginVersionFirebase featureSource code
cloud_firestorepub packageCloud Firestorepackages/cloud_firestore
cloud_functionspub packageCloud Functionspackages/cloud_functions
firebase_admobpub packageFirebase AdMobpackages/firebase_admob
firebase_analyticspub packageFirebase Analyticspackages/firebase_analytics
firebase_authpub packageFirebase Authenticationpackages/firebase_auth
firebase_corepub packageFirebase Corepackages/firebase_core
firebase_crashlyticspub packageFirebase Crashlyticspackages/firebase_crashlytics
firebase_databasepub packageFirebase Realtime Databasepackages/firebase_database
firebase_dynamic_linkspub packageFirebase Dynamic Linkspackages/firebase_dynamic_links
firebase_in_app_messagingpub packageFirebase In-App Messagingpackages/firebase_in_app_messaging
firebase_messagingpub packageFirebase Cloud Messagingpackages/firebase_messaging
firebase_ml_visionpub packageFirebase ML Kitpackages/firebase_ml_vision
firebase_performancepub packageFirebase Performance Monitoringpackages/firebase_performance
firebase_remote_configpub packageFirebase Remote Configpackages/firebase_remote_config
firebase_storagepub packageFirebase Cloud Storagepackages/firebase_storage

Issues #

Please file Flutterfire specific issues, bugs, or feature requests in our issue tracker.

Plugin issues that are not specific to Flutterfire can be filed in the Flutter issue tracker.

Contributing #

If you wish to contribute a change to any of the existing plugins in this repo, please review our contribution guide, and send a pull request.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/README.md

er_firestore #

Example Usage #

FirebaseFirestoreService db = new FirebaseFirestoreService();
  create() {
    final Swap swap = new Swap("", "_bio", "_email");
    db.createCollectionRef('users').then(
      (v) {
        db.create(swap, v);
      },
    );
  }

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  er_firestore: ^1.0.1+4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:er_firestore/er_firestore.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.29 points)

40 out of 41 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (firebase).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
cloud_firestore ^0.12.9 0.12.9+5
firebase ^5.0.4 5.0.4 6.0.0
firebase_auth ^0.14.0+2 0.14.0+5
firebase_core ^0.4.0+8 0.4.0+9
flutter 0.0.0
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.11 1.14.12
http 0.12.0+2
http_parser 3.1.3
js 0.6.1+1
meta 1.1.7
path 1.6.4
pedantic 1.8.0+1
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test