equatable 1.2.5

Dart native js
Flutter Android iOS web

An abstract class that helps to implement equality without needing to explicitly override == and hashCode.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  equatable: ^1.2.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:equatable/equatable.dart';
380
likes
110
pub points
99%
popularity

Publisher

fluttercommunity.dev

An abstract class that helps to implement equality without needing to explicitly override == and hashCode.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

collection, meta

More

Packages that depend on equatable