epub_kitty_lib 1.0.5

Flutter Android iOS

epub_kitty_lib is an ePub eBook reader that encapsulates the Folioreader Framework.

epub_kitty_lib #

badge badge badge

1

2

epub_kitty_lib is an epub ebook reader that encapsulates the folioreader framework. It supports iOS and android, but is customizable on iOS. It is very easy to use, you just need to set up the configuration file can open the ebook, very convenient. However, it is not yet highly customizable on android. But it has been able to meet daily needs.

Install #

  dependencies:
    epub_kitty_lib: ^1.0.5

Simple Use #

first step

    ///
    // @identifier (android useless)
    // @themeColor
    // @scrollDirection (android useless)
    // @allowSharing (android useless)
    // @shouldHideNavigationOnTap (android useless)
    ///
    EpubKitty.setConfig("book", "#32a852","vertical",true, shouldHideNavigationOnTap:false);

Second Step

  ///
  // @bookPath
  ///
  EpubReader.open('bookPath');
  // page channel used to monitor the current number of pages (only on the ios side)
  static const pageChannel = const EventChannel('com.epub_kitty_lib/page');

Welcome TO PR #

Always open to PRs, so if you find a bug or a quick fix kindly share

0
likes
100
pub points
35%
popularity

Publisher

codenka.com

epub_kitty_lib is an ePub eBook reader that encapsulates the Folioreader Framework.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on epub_kitty_lib