enum_class_generator 2.0.0

Enum Classes for Dart #

Enum Classes are now available from built_value.

Changelog #

2.0.0 #

  • Deleted. Equivalent functionality is now available from built_value.

1.1.2 #

  • Regenerate .g.dart files for built_value 0.1.6.

1.1.1 #

  • Allow quiver 0.23.

1.1.0 #

  • Upgrade analyzer, build and source_gen dependencies.

1.0.0 #

  • API now stable.
  • Refactor generator to split into logical classes.
  • Fix "watch mode": check for duplicate identifiers per library.

0.2.2 #

  • Improve error output on failure to generate.

0.2.1 #

  • Add values and valueOf to generated mixin for use in Angular templates.
  • Make duplicate generated name detection more robust.
  • Check value and valueOf using analyzed nodes instead of raw source. Makes generation robust to newlines in these declarations.

0.2.0 #

  • Add mixin generation for use with Angular templates.

0.1.0 #

  • Upgrade to source_gen 0.5.0.
  • Breaking change; see example for required changes to build.dart.

0.0.6 #

  • Check for missing import statement.
  • Fix constraints for source_gen.

0.0.5 #

  • Fix generation across multiple files, allow reuse of generated identifiers.

0.0.4 #

  • Fail on dynamic fields.
  • Export BuiltSet.
  • Allow part statements with double quote.

0.0.3 #

  • Support multiple enums in one file by allowing arbitrary generated identifiers.

0.0.2 #

  • Add accurate dependencies on SDK, analyzer.

0.0.1 #

  • Generator, tests and example.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  enum_class_generator: ^2.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

This package is not analyzed, because it is discontinued.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.