enigma 0.0.4

  • Readme
  • Changelog
  • Installing
  • 0

Enigma-dart - cross-platform (for use in server and browser), fully typed dart client for Qlik Assosiative Engine #

Examples are

To run examples you must accept the Qlik Core EULA by setting the ACCEPT_EULA environment variable and run qlikcore/engine

$ ACCEPT_EULA=yes docker-compose up -d

Simple example:

import 'package:web_socket_channel/io.dart';
import 'package:enigma/enigma.dart';

const loadScript = '''
RecNo() as ID,
Rand() as Value
AutoGenerate 100

main() async {  
  var channel = new IOWebSocketChannel.connect('ws://localhost:19076/app');
  var enigma = new Enigma(channel);
  var global = enigma.open();
  var doc = await global.createSessionApp();
  await doc.setScript(loadScript);
  await doc.doReload();
  var properties = new GenericObjectProperties((b) => b
    ..info.type = 'my-straight-hypercube'
        .add(new NxDimension((b) => b..def.fieldDefs.add('ID')))
        .add(new NxMeasure((b) => b..def.def = '=Sum(Value)'))
    ..hyperCubeDef.initialDataFetch.add(new NxPage((b) => b
      ..height = 5
      ..width = 2)));
  var object = await doc.createObject(properties);
  var layout = await object.getLayout();
  print('Hypercube data pages: ${layout.hyperCube.dataPages}');
  await object.selectHyperCubeCells('/qHyperCubeDef', [0, 2, 4], [0]);
  print('After selection (notice the `qState` values)');
  layout = await object.getLayout();
  print('Hypercube data pages: ${layout.hyperCube.dataPages}');

  await enigma.close();

Changelog #

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  enigma: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:enigma/enigma.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0