enge 0.4.0

Dart native
Flutter Android iOS

An structure builder for optimize the development for Flutter. The method is based on Laravel's way of doing this.

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate enge

2. Use it

The package has the following executables:

$ enge

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  enge: ^0.4.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:enge/commands/init_command.dart';
import 'package:enge/commands/make_component_command.dart';
import 'package:enge/commands/make_migration_command.dart';
import 'package:enge/commands/make_page_command.dart';
import 'package:enge/init/init.dart';
import 'package:enge/makers/component_maker.dart';
import 'package:enge/makers/maker.dart';
import 'package:enge/makers/migration_maker.dart';
import 'package:enge/makers/page_maker.dart';
import 'package:enge/support/script_location.dart';
0
likes
80
pub points
39%
popularity

An structure builder for optimize the development for Flutter. The method is based on Laravel's way of doing this.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

daniel1208x@gmail.com

License

MIT (LICENSE)

Dependencies

args, cooker, intl, path, slugify, sprintf

More

Packages that depend on enge