emoji_picker 0.0.2

Flutter Emoji Keyboard #

pub package

A Flutter package that provides an Emoji Keyboard widget.

Key Features #

  • View and select 390 emojis
  • 6 categories
  • Optionally add keywords to recommend emojis
  • Material Design and Cupertino mode

Usage #

To use this plugin, add emoji_picker as dependency in your pubspec.yaml file.

Sample Usage #

import 'package:flutter/material.dart';
import 'package:emoji_picker/emoji_picker.dart';

void main() => runApp(MainApp());

class MainApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: "Flutter Emoji Picker Example",
      home: Scaffold(
        appBar: AppBar(
          title: Text("Flutter Emoji Picker Example"),
        ),
        body: MainPage(),
      ),
    );
  }
}

class MainPage extends StatefulWidget {
  @override
  MainPageState createState() => new MainPageState();
}

class MainPageState extends State<MainPage> {
  @override
  Widget build(BuildContext context) {
    return EmojiPicker(
      rows: 3,
      columns: 7,
      recommendKeywords: ["racing", "horse"],
      numRecommended: 10,
      onEmojiSelected: (emoji, category) {
        print(emoji);
      },
    );
  }
}

See the example directory for the complete sample app.

[0.0.1] - 06/04/2019

  • View and select emojis
  • 6 categories
  • Optionally add keywords to recommend emojis
  • Material design and Cupertino mode

[0.0.2] - 21/04/2019

  • Removed NeverScrollableScrollPhysics class
  • Improved scroll performance

example/README.md

emoji_picker_test #

A new Flutter application.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  emoji_picker: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:emoji_picker/emoji_picker.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
84
Health:
Code health derived from static analysis. [more]
94
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
87
Overall:
Weighted score of the above. [more]
88
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.59 points)

71 out of 72 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/emoji_picker.dart. (-5.36 points)

Analysis of lib/emoji_picker.dart reported 11 hints, including:

line 25 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: EmojiPicker.selectedCategory, EmojiPicker.bgColor, EmojiPicker.indicatorColor, EmojiPicker.noRecommendationsStyle, EmojiPicker.categoryIcons, EmojiPicker.unavailableEmojiIcon

line 330 col 30: This function has a return type of 'int', but doesn't end with a return statement.

line 394 col 73: This function has a return type of 'Widget', but doesn't end with a return statement.

line 471 col 69: This function has a return type of 'Widget', but doesn't end with a return statement.

line 526 col 69: This function has a return type of 'Widget', but doesn't end with a return statement.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-3 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
device_info ^0.4.0+1 0.4.0+2
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test