emoji_chooser 0.9.2
emoji_chooser: ^0.9.2 copied to clipboard

An emoji picker component for Flutter. The current version supports Emoji version 13 (2020)

Emoji Chooser #

Emoji Chooser is an emoji picker component for Flutter.

Screenhot of emoji chooser

Brought to you by the InstaBudget team.

Getting Started #

Declare dependency in your pubspec.yaml

dependencies:
    emoji_chooser: ^0.9.2

You can then easily embed the Emoji Chooser Widget anywhere in your application:

EmojiChooser(
    onSelected: (emoji) {
        print('Selected emoji ${emoji.char}');
    },
),

You will receive a callback with an EmojiData object represented the emoji picked by the user.

class EmojiData {
  final String id;
  final String name;
  final String unified;
  final String char;
  final String category;
  final int skin;
}

When the emoji is qualified with a skin tone, both unified and char contains the qualifed values.

The skin parameter goes from 0 to 6, 0 representing no skin tone applied. 1 is then the lighter skin tone and 6 the darkest.

How to use as a keyboard #

You can use a modal sheet to simulate a keyboard.

return showModalBottomSheet(
    context: context,
    builder: (BuildContext subcontext) {
        return Container(
        height: 266,
        child: EmojiChooser(
            onSelected: (emoji) {
            Navigator.of(subcontext).pop(emoji);
            },
        ),
        );
    },
);

🎩 Hat tips! #

Powered by iamcal/emoji-data and inspired by JeffG05/emoji_picker.
🙌🏼 Cal Henderson.

1
likes
90
pub points
36%
popularity

An emoji picker component for Flutter. The current version supports Emoji version 13 (2020)

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

poitch@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on emoji_chooser