ee 0.0.3

  • Installing
  • Versions
  • 16

event emitter for Dart #

Build Status License Dart

A Dart event emitter implementation without any dependencies.

Requirement #

  • dart>=1.20.0

Usage #

import 'package:ee/ee.dart' show EventEmitter;

void main() {
  EventEmitter event = new EventEmitter();
  event.on('say hi', (name) {
    print('Hi! $name');   // Hi! Axetroy
  event.emit('say hi', 'Axetroy');

Test #


Contribute #

git clone
cd ./event-emitter.dart
pub get

You can flow Contribute Guide

License #

The MIT License


0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  ee: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:ee/ee.dart';
Version Uploaded Documentation Archive
0.0.3 Mar 4, 2017 Go to the documentation of ee 0.0.3 Download ee 0.0.3 archive
0.0.2 Mar 4, 2017 Go to the documentation of ee 0.0.2 Download ee 0.0.2 archive
0.0.1 Mar 4, 2017 Go to the documentation of ee 0.0.1 Download ee 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.