Ready-to-use flutter audioplayer for iOS and Android. It is optimized to play educational audio from the Internet. It is based on audioplayer
A new Flutter application.
This project is a starting point for a Flutter application.
A few resources to get you started if this is your first Flutter project:
For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.
Add this to your package's pubspec.yaml file:
dependencies: educational_audioplayer: ^1.1.0
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:educational_audioplayer/loader.dart'; import 'package:educational_audioplayer/player.dart'; import 'package:educational_audioplayer/ui/audio_loader.dart'; import 'package:educational_audioplayer/ui/bottom_player.dart'; import 'package:educational_audioplayer/ui/common_player.dart'; import 'package:educational_audioplayer/util/constants.dart'; import 'package:educational_audioplayer/util/loader.dart'; import 'package:educational_audioplayer/util/shared_preferences.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Aug 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
lib/ui/audio_loader.dart. (-1 points)
lib/ui/audio_loader.dart reported 2 hints:
line 137 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
line 165 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
lib/loader.dart. (-0.50 points)
lib/loader.dart reported 1 hint:
line 45 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
lib/util/shared_preferences.dart. (-0.50 points)
lib/util/shared_preferences.dart reported 1 hint:
line 36 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (
The package description is too short. (-5 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
|Dart SDK||>=2.0.0-dev.68.0 <3.0.0|