educational_audioplayer 1.0.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 48

educational_audioplayer #

Ready-to-use flutter audioplayer for iOS and Android. It is optimized to play educational audio from the Internet. It is based on audioplayer

Features #

  • [x] Android & iOS
    • [x] bottom player
      • [x] play
      • [x] pause
      • [x] back/forward for 10 seconds
      • [x] next/previous audio
      • [x] share audio
    • [x] download/delete audio
    • [x] player notification

[0.0.1] - TODO: Add release date.

[0.8.0] - Bottom player is done

[1.0.0] - user-friendly player and audio downloading, playing notification

example/README.md

example #

A new Flutter application.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  educational_audioplayer: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:educational_audioplayer/loader.dart';
import 'package:educational_audioplayer/player.dart';
import 'package:educational_audioplayer/ui/audio_loader.dart';
import 'package:educational_audioplayer/ui/bottom_player.dart';
import 'package:educational_audioplayer/ui/common_player.dart';
import 'package:educational_audioplayer/util/constants.dart';
import 'package:educational_audioplayer/util/loader.dart';
import 'package:educational_audioplayer/util/shared_preferences.dart';
  
Version Uploaded Documentation Archive
1.0.0 Jun 13, 2019 Go to the documentation of educational_audioplayer 1.0.0 Download educational_audioplayer 1.0.0 archive
0.8.0 Apr 28, 2019 Go to the documentation of educational_audioplayer 0.8.0 Download educational_audioplayer 0.8.0 archive
0.0.1 Apr 4, 2019 Go to the documentation of educational_audioplayer 0.0.1 Download educational_audioplayer 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Jun 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.17
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/ui/audio_loader.dart. (-1 points)

Analysis of lib/ui/audio_loader.dart reported 2 hints:

line 137 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 165 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/loader.dart. (-0.50 points)

Analysis of lib/loader.dart reported 1 hint:

line 45 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/util/shared_preferences.dart. (-0.50 points)

Analysis of lib/util/shared_preferences.dart reported 1 hint:

line 36 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance suggestions

The package description is too short. (-5 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
audioplayer ^00.5.2 0.5.2
flutter 0.0.0
flutter_local_notifications ^0.4.5 0.4.5 0.7.1+3
http ^00.12.0+2 0.12.0+2
path_provider ^00.5.0+1 0.5.0+1 1.1.0
progress_hud ^1.1.0 1.1.0
share ^0.6.1 0.6.1+1
shared_preferences ^0.4.3 0.4.3 0.5.3+1
Transitive dependencies
async 2.2.0
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
pedantic 1.7.0
platform 2.2.0
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test