ecstatic 0.0.4
ecstatic: ^0.0.4 copied to clipboard

This package provides API parity with several classes of the Dart SDK but using instance properties rather than static properties.

ecstatic #

This package provides API parity with several classes of the Dart SDK but using instance properties rather than static properties.

This difference enables the use of these APIs in tests, where you can provide mock implementations.

Many of these classes are taken from the Flutter and Dart codebases.

Platform #

  • from flutter_tools/lib/src/base/platform.dart
0
likes
90
pub points
0%
popularity

This package provides API parity with several classes of the Dart SDK but using instance properties rather than static properties.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

vince.varga@serialdeveloper.com

License

BSD (LICENSE)

More

Packages that depend on ecstatic