ecb_fx 0.1.1

ecb_fx #

Foreign Exchange (FX) rates from the European Central Bank. The rates refresh around 4 PM CET daily.

Usage #

A simple usage example:

import 'dart:async';

import 'package:ecb_fx/ecb_fx.dart';
import 'package:http_client/console.dart' as http;

Future main() async {
  http.Client httpClient = new http.ConsoleClient();
  EcbFxClient ecbFxClient = new EcbFxClient(httpClient);

  EcbFxRates rates = await ecbFxClient.getCurrent();
  print('Current USD/EUR rate: ${rates.getDecimal('USD')}');
}

Changelog #

0.1.1 #

  • Support for historical query.

0.1.0 #

  • Upgraded to Dart 2.

0.0.1 #

  • Initial version.

example/example.dart

// Copyright (c) 2017, Agilord. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'dart:async';

import 'package:ecb_fx/ecb_fx.dart';
import 'package:http_client/console.dart' as http;

Future main() async {
  http.Client httpClient = new http.ConsoleClient();
  EcbFxClient ecbFxClient = new EcbFxClient(httpClient);

  EcbFxRates rates = await ecbFxClient.getCurrent();
  print('Current USD/EUR rate: ${rates.getDecimal('USD')}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ecb_fx: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ecb_fx/ecb_fx.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:ecb_fx/ecb_fx.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (http_client).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
decimal ^0.3.0 0.3.3
http_client ^0.5.0 0.5.1 1.0.4+1
xml ^3.2.0 3.5.0
Transitive dependencies
charcode 1.1.2
collection 1.14.11
convert 2.1.1
executor 2.1.2
meta 1.1.7
path 1.6.2
petitparser 2.4.0
rational 0.3.4
stack_trace 1.9.3
typed_data 1.1.6
Dev dependencies
test ^1.0.0

Admin