easy_pip 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 27

easy_pip #

A widget for creating a Picture-In-Picture interface in Flutter. Note that this is not a plugin for enabling the PIP mode in Android. EasyPIP makes it easy to construct a YouTube like interface in Flutter.

Usage #

To use this package, add easy_pip as a dependency in your pubspec.yaml

The main widget to use is PIPStack.

Example #

import 'package:flutter/material.dart';
import 'package:easy_pip/easy_pip.dart';

/...

.../

class _MyHomePageState extends State<MyHomePage> {

  var pipEnabled = false;

  @override
  Widget build(BuildContext context) {
    return new Scaffold(
      appBar: new AppBar(),
      body: PIPStack(
        backgroundWidget: Center(
          child: RaisedButton(
            onPressed: () {
              setState(() {
                pipEnabled = !pipEnabled;
              });
            },
            child: Text("Click here to enable PIP"),
          ),
        ),
        pipWidget: pipEnabled
            ? Container(
                color: Colors.pink,
              )
            : Container(),
        pipEnabled: pipEnabled,
        pipExpandedContent: Card(
          color: Colors.white,
          child: Column(
            children: <Widget>[Text("Hello World"), Row()],
          ),
        ),
        onClosed: () {
          setState(() {
            pipEnabled = !pipEnabled;
          });
        },
      ),
    );
  }
}

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - 31/07/2018

  • Initial release
  • Added PIP Stack

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  easy_pip: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:easy_pip/easy_pip.dart';
  
Version Uploaded Documentation Archive
0.1.0 Feb 9, 2019 Go to the documentation of easy_pip 0.1.0 Download easy_pip 0.1.0 archive
0.0.2 Jul 31, 2018 Go to the documentation of easy_pip 0.0.2 Download easy_pip 0.0.2 archive
0.0.1 Jul 30, 2018 Go to the documentation of easy_pip 0.0.1 Download easy_pip 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
55
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
27
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.