easy_json_dart 1.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

A library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.

Usage #

A simple usage example:

import 'package:easy_json_dart/easy_json_dart.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

1.0.0 #

  • Initial version, created by Stagehand

example/easy_json_dart_example.dart

import 'package:easy_json_dart/easy_json_dart.dart';

void main() {
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  easy_json_dart: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:easy_json_dart/easy_json_dart.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
92
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Health suggestions

Fix lib/src/json/JSONObject.dart. (-15.67 points)

Analysis of lib/src/json/JSONObject.dart reported 34 hints, including:

line 41 col 1: Prefer using /// for doc comments.

line 97 col 5: Prefer using /// for doc comments.

line 118 col 5: Prefer using /// for doc comments.

line 157 col 5: Prefer using /// for doc comments.

line 164 col 5: Prefer using /// for doc comments.

Fix lib/src/json/JSONArray.dart. (-12.22 points)

Analysis of lib/src/json/JSONArray.dart reported 26 hints, including:

line 28 col 1: Prefer using /// for doc comments.

line 55 col 5: Prefer using /// for doc comments.

line 91 col 5: Prefer using /// for doc comments.

line 98 col 5: Prefer using /// for doc comments.

line 113 col 5: Prefer using /// for doc comments.

Fix lib/src/json/JSONStringer.dart. (-11.33 points)

Analysis of lib/src/json/JSONStringer.dart reported 24 hints, including:

line 25 col 1: Prefer using /// for doc comments.

line 32 col 5: Prefer using /// for doc comments.

line 38 col 5: Prefer using /// for doc comments.

line 44 col 5: Prefer using /// for doc comments.

line 50 col 5: Prefer using /// for doc comments.

Fix additional 7 files with analysis or formatting issues. (-25.79 points)

Additional issues in the following files:

  • lib/src/json/JSONTokener.dart (18 hints)
  • lib/src/EasyJSONBase.dart (12 hints)
  • lib/src/EasyJSONArray.dart (8 hints)
  • lib/src/EasyJSONObject.dart (8 hints)
  • lib/src/json/JSON.dart (6 hints)
  • lib/src/EasyJSONException.dart (1 hint)
  • lib/src/json/Ascii.dart (Run dartfmt to format lib/src/json/Ascii.dart.)

Maintenance suggestions

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
sprintf ^4.0.0 4.0.2
Dev dependencies
pedantic ^1.8.0
test ^1.6.0