easy_gradient_text 1.0.0

  • Readme
  • Changelog
  • Installing
  • 61

easy_gradient_text #

A Flutter Widget to draw gradients into text.

Demo #

Alt Text

Install #

Add the plugin

  easy_gradient_text: ^1.0.0

Usage #

import 'package:easy_gradient_text/easy_gradient_text.dart';

Use it:

    text: 'My gradient text',
    colors: <Color>[
    style: TextStyle(fontSize: 30.0),

Parameters #

| Parameter | Required | Description | |- |- |- | | text | true | Text to show. | | colors | true | List of colors to apply. | | style | false | Text style. | | overflow | false | How visual overflow should be handled. | | textAlign | false | How the text should be aligned horizontally. | | tileMode | false | Defines what happens at the edge of the gradient. | | customGradient | false | Use a custom gradient. This will override the type following parameters: type, colors, transform and tileMode. | | gradientDirection | false | Set gradient direction. Possible values: rtl (Right to left), ltr (Left to right), ttb (Top to bottom), btt (Bottom to top) | | transform | false | Used for transforming gradient shaders without applying the same transform to the entire canvas. | | type | false | Set gradient type. Possible values: linear and radial |

[1.0.0] - Initial release #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  easy_gradient_text: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:easy_gradient_text/easy_gradient_text.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [easy_gradient_text] that is in a package requiring null.

Health suggestions

Format lib/easy_gradient_text.dart.

Run flutter format to format lib/easy_gradient_text.dart.

Maintenance suggestions

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and easy_gradient_text.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies