easy_form 0.0.7

  • Readme
  • Changelog
  • Installing
  • 16

easy_form #

Build Flutter form with ease.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  easy_form: ^0.0.7

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:easy_form/easy_form.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
16
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
16
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Fix lib/bloc.dart. (-99.87 points)

Analysis of lib/bloc.dart failed with 23 errors, including:

line 15 col 14: The name 'Observable' isn't a type so it can't be used as a type argument.

line 44 col 2: Undefined class 'Observable'.

line 56 col 2: Undefined class 'Observable'.

line 68 col 2: Undefined class 'Observable'.

line 80 col 2: Undefined class 'Observable'.

Fix lib/models.dart. (-95.78 points)

Analysis of lib/models.dart failed with 11 errors, including:

line 23 col 9: Undefined class 'Observable'.

line 25 col 9: Undefined class 'Observable'.

line 27 col 9: Undefined class 'Observable'.

line 29 col 9: Undefined class 'Observable'.

line 31 col 9: Undefined class 'Observable'.

Fix lib/provider.dart. (-0.50 points)

Analysis of lib/provider.dart reported 1 hint:

line 9 col 20: 'inheritFromWidgetOfExactType' is deprecated and shouldn't be used. Use dependOnInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/easy_form.dart (Run flutter format to format lib/easy_form.dart.)
  • lib/form_item.dart (Run flutter format to format lib/form_item.dart.)
  • lib/subscription.dart (Run flutter format to format lib/subscription.dart.)
  • lib/utils.dart (Run flutter format to format lib/utils.dart.)

Maintenance issues and suggestions

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: rxdart.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and easy_form.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
collection ^1.14.11 1.14.11 1.14.12
flutter 0.0.0
rxdart >=0.21.0 0.23.1
Transitive dependencies
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test