easy_flutter_calendar 1.0.0

  • Readme
  • Changelog
  • Installing
  • 47

flutter_calendar #

A new Flutter custom calendar.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[1.0.0] - 25 December, 2019 #

  • This is initial release of flutter calendar.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  easy_flutter_calendar: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:easy_flutter_calendar/easy_flutter_calendar.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
95
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Jul 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • easy_flutter_calendar that is a package requiring null.

Health issues and suggestions

Document public APIs. (-0.66 points)

86 out of 87 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/easy_flutter_calendar.dart. (-1.99 points)

Analysis of lib/easy_flutter_calendar.dart reported 4 hints:

line 1 col 8: Unused import: 'package:easy_flutter_calendar/model/Month.dart'.

line 2 col 8: Unused import: 'package:easy_flutter_calendar/model/WeekData.dart'.

line 3 col 8: Unused import: 'package:easy_flutter_calendar/page/EasyFlutterCalendar.dart'.

line 4 col 8: Unused import: 'package:easy_flutter_calendar/model/Week.dart'.

Fix lib/model/WeekData.dart. (-1 points)

Analysis of lib/model/WeekData.dart reported 2 hints:

line 1 col 8: Unused import: 'package:flutter/cupertino.dart'.

line 2 col 8: Unused import: 'package:flutter/material.dart'.

Fix lib/page/EasyFlutterCalendar.dart. (-1 points)

Analysis of lib/page/EasyFlutterCalendar.dart reported 2 hints:

line 8 col 7: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: EasyFlutterCalendar.selectedDate, EasyFlutterCalendar.minDate, EasyFlutterCalendar.maxDate, EasyFlutterCalendar.weekFontSize, EasyFlutterCalendar.titleFontSize, EasyFlutterCalendar.monthDayFontSize, EasyFlutterCalendar.weekTitleColor, EasyFlutterCalendar.weekHolidayTitleColor, EasyFlutterCalendar.titleColor, EasyFlutterCalendar.monthDayColor, EasyFlutterCalendar.titleFontFamily, EasyFlutterCalendar.weekFontFamily, EasyFlutterCalendar.monthDayFontFamily, EasyFlutterCalendar.selectedDayColor, EasyFlutterCalendar.weekHolidays, EasyFlutterCalendar.onDateChange, EasyFlutterCalendar.onMonthChange, EasyFlutterCalendar.onYearChange, EasyFlutterCalendar.isYearChangeAvailable

line 233 col 8: This method overrides a method annotated as '@mustCallSuper' in 'State', but doesn't invoke the overridden method.

Format lib/model/Month.dart.

Run flutter format to format lib/model/Month.dart.

Format lib/model/Week.dart.

Run flutter format to format lib/model/Week.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and easy_flutter_calendar.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
intl ^0.16.0 0.16.1
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
path 1.7.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test