Plugin to connect to the easy church API.
Getting Started #
See code under example/lib/main.dart to see how the plugin can be accessed
- TODO: Describe initial release.
Demonstrates how to use the easy_church_json plugin.
Getting Started #
The code under main illustrates how the plugin receives the information from the API
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: easy_church_json: ^0.1.7
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.1
- pana: 0.13.4
- Flutter: 1.12.13+hotfix.5
lib/src/easy_church_json.dart. (-3.93 points)
lib/src/easy_church_json.dart reported 8 hints, including:
line 125 col 55: Name non-constant identifiers using lowerCamelCase.
line 152 col 47: Name non-constant identifiers using lowerCamelCase.
line 230 col 23: The value of the local variable 'list' isn't used.
line 241 col 23: This function has a return type of 'Future
line 338 col 30: This function has a return type of 'Future
lib/src/single_church.dart. (-0.50 points)
lib/src/single_church.dart reported 1 hint:
line 43 col 29: Set literals weren't supported until version 2.2, but this code is required to be able to run on earlier versions.
flutter format to format
lib/src/single_prayer.dart reported :
line 0 col 0: is a part and cannot be analyzed.
Maintenance issues and suggestions
Homepage URL doesn't exist. (-20 points)
At the time of the analysis the
https://github.com/MawiraIke/Easy-Church-Plugin was unreachable.
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (
The description is too long. (-2 points)
Search engines display only the first part of the description. Try to keep the value of the
description field in your package's
pubspec.yaml file between 60 and 180 characters.
|Dart SDK||>=2.1.0 <3.0.0|