easy_church_json 0.1.7

  • Readme
  • Changelog
  • Example
  • Installing
  • 51

easy_church_json #

Plugin to connect to the easy church API.

Getting Started #

See code under example/lib/main.dart to see how the plugin can be accessed

0.1.7 #

  • TODO: Describe initial release.

example/README.md

easy_church_json_example #

Demonstrates how to use the easy_church_json plugin.

Getting Started #

The code under main illustrates how the plugin receives the information from the API

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  easy_church_json: ^0.1.7

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:easy_church_json/easy_church_json.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
17
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
68
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Nov 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/easy_church_json.dart. (-3.93 points)

Analysis of lib/src/easy_church_json.dart reported 8 hints, including:

line 125 col 55: Name non-constant identifiers using lowerCamelCase.

line 152 col 47: Name non-constant identifiers using lowerCamelCase.

line 230 col 23: The value of the local variable 'list' isn't used.

line 241 col 3: This function has a return type of 'Future

line 338 col 3: This function has a return type of 'Future

Fix lib/src/single_church.dart. (-0.50 points)

Analysis of lib/src/single_church.dart reported 1 hint:

line 43 col 29: Set literals weren't supported until version 2.2, but this code is required to be able to run on earlier versions.

Format lib/src/single_event.dart.

Run flutter format to format lib/src/single_event.dart.

Fix lib/src/single_prayer.dart.

Analysis of lib/src/single_prayer.dart reported :

line 0 col 0: is a part and cannot be analyzed.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/MawiraIke/Easy-Church-Plugin was unreachable.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (dio).

The description is too long. (-2 points)

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
dio ^2.1.0 2.2.2 3.0.5
flutter 0.0.0
http ^0.12.0+2 0.12.0+2
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.11 1.14.12
cookie_jar 1.0.1
http_parser 3.1.3
meta 1.1.7 1.1.8
path 1.6.4
pedantic 1.8.0+1
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test