dynamic_material_app 0.0.1

  • Readme
  • Changelog
  • Installing
  • new54

Dynamic Material App Widget #

This widget automatically decides theme mode depending on the light in the surroundings.This only works for an Android app.

Install #

Add dynamic_material_app as a dependency in pubspec.yaml. For help on adding as a dependency, view the documentation.

Usage #

First import package.

import 'package:dynamic_material_app/theme_data_bloc.dart';

Add the following line in main.dart.

void main(){
  WidgetsFlutterBinding.ensureInitialized();
  runApp(MyApp());
}

Add this widget as root widget.



class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return DynamicMaterialApp(
      theme: ThemeData.light(), //You can give your custom light mode theme.
      
      darkTheme: ThemeData.dark(), //You can give your custom dark mode theme.
       
      home: Scaffold(),
    );
  }
}

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dynamic_material_app: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dynamic_material_app/dynamic_material_app.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
23
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
54
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:dynamic_material_app/dynamic_material_app.dart, package:dynamic_material_app/theme_data_bloc.dart, package:light/light.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:dynamic_material_app/dynamic_material_app.dart, package:dynamic_material_app/theme_data_bloc.dart, package:light/light.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:dynamic_material_app/dynamic_material_app.dart, package:dynamic_material_app/theme_data_bloc.dart, package:light/light.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:dynamic_material_app/dynamic_material_app.dart, package:dynamic_material_app/theme_data_bloc.dart, package:light/light.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [dynamic_material_app] that is in a package requiring null.

Health suggestions

Format lib/dynamic_material_app.dart.

Run flutter format to format lib/dynamic_material_app.dart.

Format lib/theme_data_bloc.dart.

Run flutter format to format lib/theme_data_bloc.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dynamic_material_app.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
light ^0.1.1 0.1.1
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test