dropdown_menu 1.1.1

flutter_dropdown_menu #

A dropdown menu for Flutter.

Showcase #

showcase


showcase

showcase

Table of contents #

Installion #

dropdown_menu: ^1.1.0

Build simple list menu #

Build tree menu #

Build custom menu #

How to use #



Examples #

seemain.dart

[1.0.0] - [2018/05/25]

* Basic Usage

[1.0.1] - [2018/05/25]

* Fix index change bug when switchStyle=DropdownMenuShowHideSwitchStyle.directHideAnimationShow
* Add index change swith animation style : DropdownMenuShowHideSwitchStyle.directHideDirectShow

[1.1.0] - [2018/05/27]

* Add fix-head DorpdownMenu
* Add scrollview DropdownMenu

example/README.md

example #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dropdown_menu: ^1.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dropdown_menu/dropdown_menu.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
86
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
89
Learn more about scoring.

We analyzed this package on Aug 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/_src/dropdown_menu.dart. (-0.50 points)

Analysis of lib/_src/dropdown_menu.dart reported 1 hint:

line 2 col 29: The name Image is shown, but not used.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.48.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test