dropdown_menu 1.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 87

flutter_dropdown_menu #

A dropdown menu for Flutter.

Showcase #




Table of contents #

Installion #

dropdown_menu: ^1.1.0

Build simple list menu #

Build tree menu #

Build custom menu #

How to use #

Examples #


[1.0.0] - [2018/05/25]

* Basic Usage

[1.0.1] - [2018/05/25]

* Fix index change bug when switchStyle=DropdownMenuShowHideSwitchStyle.directHideAnimationShow
* Add index change swith animation style : DropdownMenuShowHideSwitchStyle.directHideDirectShow

[1.1.0] - [2018/05/27]

* Add fix-head DorpdownMenu
* Add scrollview DropdownMenu


example #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dropdown_menu: ^1.1.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dropdown_menu/dropdown_menu.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 17, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Fix lib/_src/drapdown_common.dart. (-0.50 points)

Analysis of lib/_src/drapdown_common.dart reported 1 hint:

line 67 col 17: 'inheritFromWidgetOfExactType' is deprecated and shouldn't be used. Use dependOnInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..

Fix lib/_src/dropdown_menu.dart. (-0.50 points)

Analysis of lib/_src/dropdown_menu.dart reported 1 hint:

line 2 col 29: The name Image is shown, but not used.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-16.99 points)

The package was last published 61 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.48.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies