draggable_fab 0.1.1

  • README.md
  • Example
  • Installing
  • Versions
  • 77

draggable_fab #

A Draggable FAB wrapper widget which can dragged to any edge of the screen.

Installation #

Add draggable_fab: ^0.1.1 in your pubspec.yaml dependencies. And import it:

import 'package:draggable_fab/draggable_fab.dart';

How to use #

Create a standalone widget e.g. Floating Action Bar widget :

        child: FloatingActionButton(
          onPressed: _incrementCounter,
          child: Icon(Icons.add),


[0.1.0] - March 12, 2019

  • Initial release

[0.1.1] - March 12, 2019

  • Added example code


draggable_fab_example #

A sample Flutter application to demonstrate draggable_fab package.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  draggable_fab: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:draggable_fab/draggable_fab.dart';
Version Uploaded Documentation Archive
0.1.1 Mar 12, 2019 Go to the documentation of draggable_fab 0.1.1 Download draggable_fab 0.1.1 archive
0.1.0 Mar 12, 2019 Go to the documentation of draggable_fab 0.1.0 Download draggable_fab 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 25, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies