douglas_peucker 0.0.4

Dart native js
Flutter Android iOS web

polyline simplification it uses a combination of Douglas-Peucker and Radial Distance algorithms. Polyline simplification dramatically reduces the number of points in a polyline while retaining its sh

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  douglas_peucker: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:douglas_peucker/douglas_peucker.dart';
0
likes
70
pub points
54%
popularity

polyline simplification it uses a combination of Douglas-Peucker and Radial Distance algorithms. Polyline simplification dramatically reduces the number of points in a polyline while retaining its shape, giving a huge performance boost when processing it and also reducing visual noise. For example, it's essential when rendering a 70k-points line chart or a map route in the browser using Canvas or SVG.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

dsmr.apps@gmail.com

License

MIT (LICENSE)

More

Packages that depend on douglas_peucker