dotless_i 0.1.6

dotless_i #

This project is discontinued. Please use turkish instead.


import 'package:dotless_i/dotless_i.dart';

main() {
  // upperCaseTr
  var inputL = "kısa şiir"; 
  print("UpperCase for [$inputL]");
  print("Default= ${inputL.toUpperCase()}, Turkish=${toUpperCaseTr(inputL)}\n");
  // lowerCaseTr
  var inputU = "KISA ŞİİR";  
  print("LowerCase for [$inputU]");
  print("Default= ${inputU.toLowerCase()}, Turkish=${toLowerCaseTr(inputU)}\n");  
  // sort Default
  var list = ["Az","ağ","aç","ad"];
  print("Input= $list");
  print("Default Sort= ${list..sort()}");
  // sort Turkish  
  list = ["Az","ağ","aç","ad"];  
  print("Turkish Sort= ${list..sort(TURKISH_STRING_COMPARATOR)}"); 
  // sort Turkish ignore case  
  list = ["Az","ağ","aç","ad"];  
  print("Turkish Sort Ignore Case= ${list..sort(TURKISH_STRING_COMPARATOR_IGNORE_CASE)}");  

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dotless_i: ^0.1.6

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dotless_i/dotless_i.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=0.8.10+6 <2.0.0